Skip to main content

Muse Hub won't install - requires helper it can't connect to

Comments

4 comments

  • Official comment
    David
    Hub Team

    Can you try deleting the com.muse.museservice file from Macintosh HD/Library/PrivilegedHelperTools folder?

    Once you've deleted that you should be able to then launch the Hub again and reinstall the Helper.

    Please note that to save content to an external drive, you'll need to give Muse Hub permissions for Full Disk Access in macOS system preference (otherwise, macOS will block attempts to write to folders other than "allowed" system folders and Muse Hub's own container. 

    To do this, open System Preferences, click Privacy & Security and then go to "Full Disk Access". You'll see a few apps, most likely, in that list. You may also see Muse Hub - if not, click the + icon and then choose the Muse Hub app from your /Applications folder. 

    That should let you work with removable drives/external disks more easily in the future.

    Hope that helps!

  • Jason Knox

    I appreciate the help, David. Unfortunately deleting that com.muse.museservice file and restarting MuseHub led to the same result (the error message in my original post). I then tried deleting the app, deleting that com.muse.museservice file again, and reinstalling MuseHub. Again, same error message when I tried to start up MuseHub.

    Could there be other buried files that are staying on my system despite deleting the app? Could those files be causing the issue?

    Thanks!

    0
  • Jason Knox

    Oh wait... I decided to look into the "Full Disk Access" fix for sounds on an external drive (located under the "Privacy" tab and then Full Disk Access is a folder in the list on the left, for anyone who might be having a similar issue). Once I made that change, the Helper error message stopped showing up and MuseHub opened right up the next time I tried it. Hopefully that did the trick. Thanks again for the help!

    0
  • Andy Kapetanakis

    I tried both these methods and it still won't work for me. Musescore will open fine if I open it from the launchpad, but Musesounds won't be playable.

    0

Please sign in to leave a comment.